11 posts / 0 new
Last post
Exporting to FreeCAD

I can't seem to export my BikeCAD file to FreeCAD. I get some error messages when I hit the green play button, but don't know enough about what I'm looking at to determine what is wrong. Anyone help?

 

Thanks in advance. 

 

Install requests library

Looks like you need to install the requests library as described at: bikecad.ca/freecad_requests.

Thanks Brent. It seems to be

Thanks Brent. It seems to be working now but only partially. I get the rims, tires, the rear triangle and the water bottle bosses on the down tube. The rest is missing. Strange. Maybe I'll redownload everything the start over. 

No front triangle

Don't bother reinstalling everything. I've seen that scenario before. Were you using a variable diameter head tube? In my experience, variable diameter head tubes sometimes don't interface well with the top tube and down tube, so all those tubes sometimes fail to appear. If you use a constant diameter head tube, you can expect more reliable results. I'm not sure if there's anything I can do at my end to produce a more robust model when using a variable diameter head tube, but that's something I'll try to work on in the future.

Yup, I have a tapered HT in

Yup, I have a tapered HT in the model. I'll swap it for a constant diameter and see if that helps. 

Thanks Brent. 

problem when using the Script download

Does anyone come across this error message when running the script macro.py?

It comes up with this error message:

 

18:57:45 Something went wrong with the pip install/upgrade of requests, possibly does not exist.

 

Version of FreeCAD

One user got this message when running an older version of FreeCAD. Have you tried this on the current version which is 0.19.2?

Hi Brent,

Hi Brent,

 

I tried this on 0.19.2 and am getting the same "Something went wrong with the pip install/upgrade of requests, possibly does not exist" message

FreeCAD Requests library

It should only be necessary to install the Requests library on the PC version of FreeCAD. Aren't you on a Mac?

It looks like you've downloaded BikeCAD for older Macs. Be aware that any MacOS from 10.7.5 onward should run the code signed version of BikeCAD.

BikeCADPro_17.1_PC

I downloaded BikeCADPro_17.1_PC.zip and installed it on my work Dell Latitude 5401, which I'm working on and messaging you from. No Macs in my workflow! I'm not sure why/how I downloaded any other version. clumsy fingers clearly!

I can't even unistall and reinstall freecad due to work IT admin rights. Nightmare!

FreeCAD Requests library

I'm sorry to hear about the ongoing troubles. I'm guessing that the same permission levels that are preventing you from uninstalling FreeCAD are also preventing you from installing this library. Perhaps you can speak to the IT department about this?

Log in or register to post comments